Degraded SMS Delivery in Select Regions

Incident Report for Verto

Monitoring

Good news:
Our vendor has resolved the SMS delivery issues for the MTN network in Cameroon and the Vodafone network in the UK.

Please note that users in the UAE (on Du and Etisalat networks) are still impacted.
We will continue monitoring the situation for the UAE.
Posted Mar 02, 2026 - 05:12 UTC

Identified

We are currently experiencing degraded performance with SMS delivery due to a downstream carrier issue with our SMS provider.
Users in the following regions may experience delays or failures when receiving SMS messages, including OTPs and notifications:

Middle East & Africa:
- UAE (specifically on the Du and Etisalat networks)
- Cameroon (specifically on the MTN network)

Europe:
- UK (specifically on the Vodafone UK network)

Impact:
If you are located in these regions and using these specific networks, you may be temporarily unable to receive text messages from us. SMS delivery for all other regions and networks is operating normally.

Next Steps:
We are actively monitoring the situation with our provider as their engineers work with local carriers to resolve the issue. We will update this page as soon as we have more information or when full service is restored. We apologize for the inconvenience and appreciate your patience
Posted Feb 19, 2026 - 11:13 UTC
This incident affects: Notifications (SMS).